Main link: https://www.urionlinejudge.com.br/judge/en/problems/view/1072
URI Online Judge | 1072
Interval 2
Adapted by Neilor Tonin, URI Brazil
Timelimit: 1
Read an integer N. This N will be the number of integer numbers X that will be read.
Print how many these numbers X are in the interval [10,20] and how many values are out of this interval.
Input
The first line of input is an integer N (N < 10000), that indicates the total number of test cases.
Each case is an integer number X (-107 < X < 107).
Each case is an integer number X (-107 < X < 107).
Output
For each test case, print how many numbers are in and how many values are out of the interval.
Input Sample | Output Sample |
4 14 123 10 -25 | 2 in 2 out |
URI Online Judge Solution 1072 in Java
import java.io.IOException;
import java.util.Scanner;
public class Main {
public static void main(String[] args) throws IOException {
int N , X, in = 0, out = 0;
int interval_start =10,interval_end =20 ;
Scanner input =new Scanner(System.in);
N =input.nextInt();
for (int i = 1; i <= N; i++) {
X =input.nextInt();
if (X >= interval_start && X <= interval_end) {
in += 1;
}else {
out += 1;
}
}
System.out.print(in+" in\n"+out +" out\n");
}
}
This comment has been removed by the author.
ReplyDeleteVisit apkdiary for more solutions like this.
ReplyDelete