Thursday, May 26, 2016

URI Online Judge Solution 1018 || Banknotes

URI Online Judge | 1018

Banknotes

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
In this problem you have to read an integer value and calculate the smallest possible number of banknotes in which the value may be decomposed. The possible banknotes are 100, 50, 20, 10, 5, 2 e 1. Print the read value and the list of banknotes.

Input

The input file contains an integer value (0 < < 1000000).

Output

Print the read number and the minimum quantity of each necessary banknotes in Portuguese language, as the given example. Do not forget to print the end of line after each line, otherwise you will receive “Presentation Error”.
Input SampleOutput Sample
576576
5 nota(s) de R$ 100,00
1 nota(s) de R$ 50,00
1 nota(s) de R$ 20,00
0 nota(s) de R$ 10,00
1 nota(s) de R$ 5,00
0 nota(s) de R$ 2,00
1 nota(s) de R$ 1,00
1125711257
112 nota(s) de R$ 100,00
1 nota(s) de R$ 50,00
0 nota(s) de R$ 20,00
0 nota(s) de R$ 10,00
1 nota(s) de R$ 5,00
1 nota(s) de R$ 2,00
0 nota(s) de R$ 1,00
503503
5 nota(s) de R$ 100,00
0 nota(s) de R$ 50,00
0 nota(s) de R$ 20,00
0 nota(s) de R$ 10,00
0 nota(s) de R$ 5,00
1 nota(s) de R$ 2,00
1 nota(s) de R$ 1,00



URI Online Judge Solution 1018 || Banknotes in C Language



#include <stdio.h>
int main()
{
    int n;
    scanf("%d", &n);
    printf("%d\n", n);
    printf("%d nota(s) de R$ 100,00\n", n/100);
    n %= 100;
    printf("%d nota(s) de R$ 50,00\n", n/50);
    n %= 50;
    printf("%d nota(s) de R$ 20,00\n", n/20);
    n %= 20;
    printf("%d nota(s) de R$ 10,00\n", n/10);
    n %= 10;
    printf("%d nota(s) de R$ 5,00\n", n/5);
    n %= 5;
    printf("%d nota(s) de R$ 2,00\n", n/2);
    n %= 2;
    printf("%d nota(s) de R$ 1,00\n", n);
    return 0;
}


URI Online Judge Solution 1018 || Banknotes in C++ Language

#include <iostream>

using namespace std;

int main(){
    int inteiro, aux;
    
    cin >> inteiro;
    
    cout << inteiro <<"\n";
    cout << inteiro/100 << " nota(s) de R$ 100,00\n";
    aux = (inteiro%100);
    cout << aux/50 << " nota(s) de R$ 50,00\n";
    aux = (aux%50);
    cout << aux/20 << " nota(s) de R$ 20,00\n";
    aux = (aux%20);
    cout << aux/10 << " nota(s) de R$ 10,00\n";
    aux = (aux%10);
    cout << aux/5 << " nota(s) de R$ 5,00\n";
    aux = (aux%5);
    cout << aux/2 << " nota(s) de R$ 2,00\n";
    aux = (aux%2);
    cout << aux/1 << " nota(s) de R$ 1,00\n";
    return 0;
}



Tags : URI Online Judge Solution 1018, URI 1018 Solution in C, URI 1018 solution in C++
See and Download Code from DropboxIf Ady happen, Just skip it
URI Link :

No comments:
Write comments

To know more about the problem, give us your valuable commment. We'll try to help you. Thanks

All rights reserved ©2016 -URI ONLINE JUDGE SOLUTION | Developed by Maniruzzaman Akash

© 2016 URI ONLINE JUDGE SOLUTION. Developed by Maniruzzaman Akash | Distributed By Gooyaabi Templates
Powered by Blogger.