URI Online Judge | 1064
Positives and Average
Adapted by Neilor Tonin, URI Brazil
Timelimit: 1
Read 6 values that can be floating point numbers. After, print how many of them were positive. In the next line, print the average of all positive values typed, with one digit after the decimal point.
Input
The input consist in 6 numbers that can be integer or floating point values. At least one number will be positive.
Output
The first output value is the amount of positive numbers. The next line should show the average of the positive values typed.
Input Sample | Output Sample |
7 -5 6 -3.4 4.6 12 | 4 valores positivos 7.4 |
URI Online Judge Solution 1064 in Java language
import java.io.IOException;
import java.util.Scanner;
public class Main {
public static void main(String[] args) throws IOException {
float n1,total = 0,average = 0;
int totalNumber = 0;
Scanner sc =new Scanner(System.in);
for (int i = 1; i <= 6; i++) {
n1 =sc.nextFloat();
if (n1 > 0) {
totalNumber += 1;
total += n1;
}
}
average = total / totalNumber;
System.out.print(totalNumber+" valores positivos\n");
System.out.printf("%.1f\n",average);
}
}
URI Online Judge Solution 1064 in C language
#include<stdio.h>
int main(){
float n1,total = 0,average = 0;
int i, totalNumber = 0;
Scanner sc =new Scanner(System.in);
for (i = 1; i <= 6; i++) {
scanf("%f", &n1);
if (n1 > 0) {
totalNumber += 1;
total += n1;
}
}
average = total / totalNumber;
printf("%d valores positivos\n", totalNumber);
printf("%.1f\n",average);
}
No comments:
Write commentsTo know more about the problem, give us your valuable commment. We'll try to help you. Thanks