URI Online Judge | 1046
Game Time
Adapted by Neilor Tonin, URI Brazil
Timelimit: 1
Read the start time and end time of a game, in hours. Then calculate the duration of the game, knowing that the game can begin in a day and finish in another day, with a maximum duration of 24 hours. The message must be printed in portuguese “O JOGO DUROU X HORA(S)” that means “THE GAME LASTED X HOUR(S)”
Input
Two integer numbers representing the start and end time of a game.
Output
Print the duration of the game as in the sample output.
Input Sample | Output Sample |
16 2 | O JOGO DUROU 10 HORA(S) |
0 0 | O JOGO DUROU 24 HORA(S) |
2 16 | O JOGO DUROU 14 HORA(S) |
URI Online Judge Solution 1046 || Game Time in C language
#include <stdio.h>
int
main()
{
int
strtTm, endTm, durationTm;
scanf
(
"%d %d"
, &strtTm, &endTm);
durationTm = endTm - strtTm;
if
(durationTm < 0)
{
durationTm = 24 + (endTm - strtTm);
}
if
(strtTm == endTm)
{
printf
(
"O JOGO DUROU 24 HORA(S)\n"
);
}
else
printf
(
"O JOGO DUROU %d HORA(S)\n"
, durationTm);
return
0;
}
See code in Dropbox or free download
Question link in URI
No comments:
Write commentsTo know more about the problem, give us your valuable commment. We'll try to help you. Thanks