Thursday, May 26, 2016

URI Online Judge Solution 1015 || Distance Between Two Points

URI Online Judge | 1015

Distance Between Two Points

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Read the four values corresponding to the x and y axes of two points in the plane, p1 (x1, y1) and p2 (x2, y2) and calculate the distance between them, showing four decimal places after the comma, according to the formula:
Distance = 

Input

The input file contains two lines of data. The first one contains two double values: x1 y1 and the second one also contains two double values with one digit after the decimal point: x2 y2.

Output

Calculate and print the distance value using the provided formula, with 4 digits after the decimal point.
Input SampleOutput Sample
1.0 7.0
5.0 9.0
4.4721
-2.5 0.4
12.1 7.3
16.1484
2.5 -0.4
-12.2 7.0
16.4575



URI Online Judge Solution 1015 || Distance Between Two Points in C language



#include<stdio.h>
#include<math.h>
 
int main()
{
    double x1, y1, x2, y2, p1, p2, distance;
    scanf("%lf %lf %lf %lf", &x1, &y1, &x2, &y2);
    p1 = x2 - x1;
    p2= y2 - y1;
    distance = sqrt((p1 * p1) + (p2 * p2));
    printf("%.4lf\n", distance);
    return 0;
}



    URI Link



1 comment:
Write comments
  1. WHen you guys take input then first make sure you take input two different line, likely(cin>>x1>>y1;cin>>x2>>y2;) otherwise uri compiler says wrong.

    ReplyDelete

To know more about the problem, give us your valuable commment. We'll try to help you. Thanks

All rights reserved ©2016 -URI ONLINE JUDGE SOLUTION | Developed by Maniruzzaman Akash

© 2016 URI ONLINE JUDGE SOLUTION. Developed by Maniruzzaman Akash | Distributed By Gooyaabi Templates
Powered by Blogger.