Thursday, May 26, 2016

URI Online Judge Solution 1011 || Sphere


URI Online Judge | 1011

Sphere

Adapted by Neilor Tonin, URI  Brazil
Timelimit: 1
Make a program that calculates and shows the volume of a sphere being provided the value of its radius (R) . The formula to calculate the volume is: (4/3) * pi * R3. Consider (assign) for pi the value 3.14159.
Tip: Use (4/3.0) or (4.0/3) in your formula, because some languages (including C++) assume that the division's result between two integers is another integer. :)

Input

The input contains a value of floating point (double precision).

Output

The output must be a message "VOLUME" like the following example with a space before and after the equal signal. The value must be presented with 3 digits after the decimal point.
Input SamplesOutput Samples
3VOLUME = 113.097
15VOLUME = 14137.155
1523VOLUME = 14797486501.627


URI Online Judge Solution 1011 || Sphere in C language :


#include<stdio.h>
int main()
{
    int R;
    double V;
    scanf("%d", &R);
 
    V = ((4.0 / 3) *3.14159 * R * R * R);
    printf("VOLUME = %.3lf\n", V);
    return 0;
}


See Code in Dropbox or Download it

No comments:
Write comments

To know more about the problem, give us your valuable commment. We'll try to help you. Thanks

All rights reserved ©2016 -URI ONLINE JUDGE SOLUTION | Developed by Maniruzzaman Akash

© 2016 URI ONLINE JUDGE SOLUTION. Developed by Maniruzzaman Akash | Distributed By Gooyaabi Templates
Powered by Blogger.